use strict;
my $str = '```php
$foo = \'Bar\';
define(\'FOO\', \'BAR\');
```
```$foo = \'Bar\';```Foobarbaz
Foobarbaz```$foo = \'Bar\';```
/(?P<start>\\```)(?<=\\```)(?P<lang>[a-z][a-z0-9]*\\s)?(?P<content>.*?)(?=\\```)(?P<end>\\```)/gs
(?<!\\\\)(?P<start>```)(?<=```)(?P<lang>[a-z][a-z0-9]*\\s)?(?P<content>.*?)(?<!\\\\)(?=```php )(?P<end>(?:\\\\\\\\)*```)
';
my $regex = qr/(?<!\\)(?P<start>```)(?<=```)(?:(?P<lang>[a-z][a-z0-9]*)\s)?(?P<content>.*?)(?<!\\)(?=```)(?P<end>(?:\\\\)*```)/sp;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}