import Foundation
let pattern = #"(?<!\\)(?P<start>```)(?<=```)(?:(?P<lang>[a-z][a-z0-9]*)\s)?(?P<content>.*?)(?<!\\)(?=```)(?P<end>(?:\\\\)*```)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
```php
$foo = 'Bar';
define('FOO', 'BAR');
```
```$foo = 'Bar';```Foobarbaz
Foobarbaz```$foo = 'Bar';```
/(?P<start>\```)(?<=\```)(?P<lang>[a-z][a-z0-9]*\s)?(?P<content>.*?)(?=\```)(?P<end>\```)/gs
(?<!\\)(?P<start>```)(?<=```)(?P<lang>[a-z][a-z0-9]*\s)?(?P<content>.*?)(?<!\\)(?=```php )(?P<end>(?:\\\\)*```)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)