import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^[:print:]]\\[[^a-zA-Z]*[a-zA-Z]";
final String string = "[BEGIN TYPESCRIPT]\n"
+ "[H[JLinux dcim-mao 4.19.0-20-cloud-amd64 #1 SMP Debian 4.19.235-1 (2022-03-17) x86_64\n\n"
+ "The programs included with the Debian GNU/Linux system are free software;\n"
+ "the exact distribution terms for each program are described in the\n"
+ "individual files in /usr/share/doc/*/copyright.\n\n"
+ "Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent\n"
+ "permitted by applicable law.\n"
+ "Last login: Mon Jul 10 08:00:55 2023 from 172.17.0.2\n\n"
+ "[?2004hroot@dcim-mao:~# cd\n"
+ "[?2004l\n"
+ "[?2004hroot@dcim-mao:~# ls\n"
+ "[?2004l\n"
+ "[?2004hroot@dcim-mao:~# cd /\n"
+ "[?2004l\n"
+ "[?2004hroot@dcim-mao:/# ls\n"
+ "[?2004l\n"
+ "app etc media public srv usr\n"
+ "bin home mnt root supervisor.conf var\n"
+ "boot lib opt run sys\n"
+ "dev lib64 proc sbin tmp\n"
+ "[?2004hroot@dcim-mao:/# \n"
+ "[END TYPESCRIPT]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}