use strict;
my $str = 'I\'m searching for **my 12 *funny* words inside my** unfunny text
';
my $regex = qr/\*\*(?=[\w|\s])/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";