re = /^((?:.*? )?(?:[Ll]ist|[Tt]able|[Ff]igure)\s+\d+(?:-\d+)?):\s+(.+)/
str = 'Text Table 6-2: Management of children study and actions'
# Print the match result
str.match(re) do |match|
puts match.to_s
end