#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<table[^>]*>(.*?)<\/table>"
Local $sString = "<table id="tbl" class="table-fill">" & @CRLF & _
"<thead>" & @CRLF & _
"<tr>" & @CRLF & _
"<th>IP</th>" & @CRLF & _
"<th>Port</th>" & @CRLF & _
"<th>Anonymity</th>" & @CRLF & _
"<th>Country</th>" & @CRLF & _
"</tr>" & @CRLF & _
"</thead>" & @CRLF & _
"<tbody id="tabli" class="table-hover">" & @CRLF & _
"<tr>" & @CRLF & _
"<td>84.17.51.209</td>" & @CRLF & _
"<td>3128</td>" & @CRLF & _
"<td>Transparent</td>" & @CRLF & _
"<td>United Kingdom</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td>84.17.51.209</td>" & @CRLF & _
"<td>3128</td>" & @CRLF & _
"<td>Transparent</td>" & @CRLF & _
"<td>United Kingdom</td>" & @CRLF & _
"</tr>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")