#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^.]+)\..*|^(.{10}).*"
Local $sString = "Lorem ipsum dolor sit amet. consectetur" & @CRLF & _
"Donec quis turpis sed sapien ullamcorper viverra sodales a est"
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)