use strict;
my $str = 'Lorem ipsum dolor sit amet. consectetur
Donec quis turpis sed sapien ullamcorper viverra sodales a est';
my $regex = qr/^([^.]+)\..*|^(.{10}).*/mp;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";