import Foundation
let pattern = #"^([^.]+)\..*|^(.{10}).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Lorem ipsum dolor sit amet. consectetur
Donec quis turpis sed sapien ullamcorper viverra sodales a est
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)