import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^<(JeEntity|JeFeld)>";
final String string = "\n"
+ " #region Satz-Definitionen\n"
+ "<JeEntity>\n"
+ " public class «EntityName»_Satz\n"
+ " {\n"
+ " #region constructor\n"
+ " public «EntityName»_Satz()\n"
+ " {\n\n"
+ " }\n"
+ " #endregion\n"
+ "<JeFeld>\n"
+ " public «FeldTyp» «FeldNameCSharp» { get; set; }\n"
+ "</JeFeld>\n"
+ " }\n"
+ "</JeEntity>\n"
+ " #endregion\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}