$re = '/\{(?<contents>(([^\{\}|(\r?\n)]*)|(\{[^\{\}|(\r?\n)]*\})|(.*?))*)\}/m';
$str = '{ int a= 0; arg2, arg3, {arg4}, \'{pip\' }
void XMLPrinter::PushHeader( bool writeBOM, bool writeDec )
{
if ( writeBOM ) {
static const unsigned char bom[] = { TIXML_UTF_LEAD_0, TIXML_UTF_LEAD_1, TIXML_UTF_LEAD_2, 0 };
Write( reinterpret_cast< const char* >( bom ) );
}
if ( writeDec ) {
PushDeclaration( "xml version=\\"1.0\\"" );
}
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);