re = /(?<sign>[+-])?(?<int>\d(?:[\d_ ]*\d+)?)(?:(?:\s*[,.]\s*)(?<decimal>\d(?:[\d_ ]*\d+)?))?/
str = '25
15,81
94.5498
+897
151 516,561 894
89.9894_56
-9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end