Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(\s*=.*;)
/
g
Input 1
1
New
class TypeInfo; TURBO_CLASS() //uywefbcgfwbcrgbycbcuynuyb class TestClass : private Test, public TestTest, protected BaseClass { TURBO_CLASS_H_GENERATION() private: TestClass * tc; TURBO_PROPERTY() std::string var1 = "Default" ; //Reflected TURBO_PROPERTY() int var2 = 2; //Reflected TestClass* tc2; TURBO_PROPERTY() int var3 = 3; //Reflected public: TestClass() = default; TestClass(std::string&& s, int i, int i2); }; TURBO_CLASS() //uywefbcgfwbcrgbycbcuynuyb class TestClass2 : private Test, public TestTest, protected BaseClass { TURBO_CLASS_H_GENERATION() private: TestClass * tc; TURBO_PROPERTY() std::string var1 = "Default" ; //Reflected TURBO_PROPERTY() int var2 = 2; //Reflected TestClass* tc2; TURBO_PROPERTY() int var3 = 3; //Reflected public: TestClass() = default; TestClass(std::string&& s, int i, int i2); }; #endif
Substitution
;
class TypeInfo; TURBO_CLASS() //uywefbcgfwbcrgbycbcuynuyb class TestClass : private Test, public TestTest, protected BaseClass { TURBO_CLASS_H_GENERATION() private: TestClass * tc; TURBO_PROPERTY() std::string var1 = "Default" ; //Reflected TURBO_PROPERTY() int var2 = 2; //Reflected TestClass* tc2; TURBO_PROPERTY() int var3 = 3; //Reflected public: TestClass() = default; TestClass(std::string&& s, int i, int i2); }; TURBO_CLASS() //uywefbcgfwbcrgbycbcuynuyb class TestClass2 : private Test, public TestTest, protected BaseClass { TURBO_CLASS_H_GENERATION() private: TestClass * tc; TURBO_PROPERTY() std::string var1 = "Default" ; //Reflected TURBO_PROPERTY() int var2 = 2; //Reflected TestClass* tc2; TURBO_PROPERTY() int var3 = 3; //Reflected public: TestClass() = default; TestClass(std::string&& s, int i, int i2); }; #endif