#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\s*=.*;)"
Local $sString = "class TypeInfo;" & @CRLF & _
"" & @CRLF & _
"TURBO_CLASS() //uywefbcgfwbcrgbycbcuynuyb" & @CRLF & _
"class TestClass : private Test, public TestTest, protected BaseClass" & @CRLF & _
"{" & @CRLF & _
" TURBO_CLASS_H_GENERATION()" & @CRLF & _
"" & @CRLF & _
" private:" & @CRLF & _
" TestClass * tc;" & @CRLF & _
"" & @CRLF & _
" TURBO_PROPERTY()" & @CRLF & _
" std::string var1 = "Default" ; //Reflected" & @CRLF & _
"" & @CRLF & _
" TURBO_PROPERTY()" & @CRLF & _
" int var2 = 2; //Reflected" & @CRLF & _
"" & @CRLF & _
" TestClass* tc2;" & @CRLF & _
"" & @CRLF & _
" TURBO_PROPERTY()" & @CRLF & _
" int var3 = 3; //Reflected" & @CRLF & _
"" & @CRLF & _
" public:" & @CRLF & _
" TestClass() = default;" & @CRLF & _
" TestClass(std::string&& s, int i, int i2);" & @CRLF & _
"};" & @CRLF & _
"" & @CRLF & _
"TURBO_CLASS() //uywefbcgfwbcrgbycbcuynuyb" & @CRLF & _
"class TestClass2 : private Test, public TestTest, protected BaseClass" & @CRLF & _
"{" & @CRLF & _
" TURBO_CLASS_H_GENERATION()" & @CRLF & _
"" & @CRLF & _
" private:" & @CRLF & _
" TestClass * tc;" & @CRLF & _
"" & @CRLF & _
" TURBO_PROPERTY()" & @CRLF & _
" std::string var1 = "Default" ; //Reflected" & @CRLF & _
"" & @CRLF & _
" TURBO_PROPERTY()" & @CRLF & _
" int var2 = 2; //Reflected" & @CRLF & _
"" & @CRLF & _
" TestClass* tc2;" & @CRLF & _
"" & @CRLF & _
" TURBO_PROPERTY()" & @CRLF & _
" int var3 = 3; //Reflected" & @CRLF & _
"" & @CRLF & _
" public:" & @CRLF & _
" TestClass() = default;" & @CRLF & _
" TestClass(std::string&& s, int i, int i2);" & @CRLF & _
"};" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"#endif"
Local $sSubst = ";"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)