import re
regex = re.compile(r"(\s*=.*;)")
test_str = ("class TypeInfo;\n\n"
"TURBO_CLASS() //uywefbcgfwbcrgbycbcuynuyb\n"
"class TestClass : private Test, public TestTest, protected BaseClass\n"
"{\n"
" TURBO_CLASS_H_GENERATION()\n\n"
" private:\n"
" TestClass * tc;\n\n"
" TURBO_PROPERTY()\n"
" std::string var1 = \"Default\" ; //Reflected\n\n"
" TURBO_PROPERTY()\n"
" int var2 = 2; //Reflected\n\n"
" TestClass* tc2;\n\n"
" TURBO_PROPERTY()\n"
" int var3 = 3; //Reflected\n\n"
" public:\n"
" TestClass() = default;\n"
" TestClass(std::string&& s, int i, int i2);\n"
"};\n\n"
"TURBO_CLASS() //uywefbcgfwbcrgbycbcuynuyb\n"
"class TestClass2 : private Test, public TestTest, protected BaseClass\n"
"{\n"
" TURBO_CLASS_H_GENERATION()\n\n"
" private:\n"
" TestClass * tc;\n\n"
" TURBO_PROPERTY()\n"
" std::string var1 = \"Default\" ; //Reflected\n\n"
" TURBO_PROPERTY()\n"
" int var2 = 2; //Reflected\n\n"
" TestClass* tc2;\n\n"
" TURBO_PROPERTY()\n"
" int var3 = 3; //Reflected\n\n"
" public:\n"
" TestClass() = default;\n"
" TestClass(std::string&& s, int i, int i2);\n"
"};\n\n\n"
"#endif")
subst = ";"
result = regex.sub(subst, test_str)
if result:
print(result)