// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\s*=.*;)").unwrap();
let string = "class TypeInfo;
TURBO_CLASS() //uywefbcgfwbcrgbycbcuynuyb
class TestClass : private Test, public TestTest, protected BaseClass
{
TURBO_CLASS_H_GENERATION()
private:
TestClass * tc;
TURBO_PROPERTY()
std::string var1 = \"Default\" ; //Reflected
TURBO_PROPERTY()
int var2 = 2; //Reflected
TestClass* tc2;
TURBO_PROPERTY()
int var3 = 3; //Reflected
public:
TestClass() = default;
TestClass(std::string&& s, int i, int i2);
};
TURBO_CLASS() //uywefbcgfwbcrgbycbcuynuyb
class TestClass2 : private Test, public TestTest, protected BaseClass
{
TURBO_CLASS_H_GENERATION()
private:
TestClass * tc;
TURBO_PROPERTY()
std::string var1 = \"Default\" ; //Reflected
TURBO_PROPERTY()
int var2 = 2; //Reflected
TestClass* tc2;
TURBO_PROPERTY()
int var3 = 3; //Reflected
public:
TestClass() = default;
TestClass(std::string&& s, int i, int i2);
};
#endif";
let substitution = ";";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}