$re = '/(?:Created by|Designer):(.*)/i';
$str = 'Created by:Wiktor
Designer:#1
Created by:Somebody like you
Designer:#2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);