#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\+?(([0-9]){1,2})[- .]|\+?([0-9]{1,15}))?((((\(?([0-9]){2,3}\)?)[- .]){1,2}([0-9]{4,10}))|([0-9]{10}))s*(?:\s*(?:#|x\.?|ext\.?|ex\.)\s*(\d+\s*?))?$"
Local $sString = "1 800 888 8078" & @CRLF & _
"+1 402.536.4184 ext 8862088" & @CRLF & _
"+91.986.964.4357" & @CRLF & _
"+972546790128" & @CRLF & _
"+972(0)74-745-4014"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")