# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d{1,2}[-\\/]\d{1,2}\s?[\-\\/]\s?\d{4}//gm;t' <<< "tetsts kmasjdkjsad kajsdkjasdkj kjadjaksd 45-12-2020 lkdlksldksd
asd sjdjska 10-11-1989 ksjdkds 1-11-1456
skdasdsa
dasdlkj kajsd kjaksdj ksadjk jsadkdj a 1/1 - 1899"