import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{1,2}[-\\/]\\d{1,2}\\s?[\\-\\/]\\s?\\d{4}";
final String string = "tetsts kmasjdkjsad kajsdkjasdkj kjadjaksd 45-12-2020 lkdlksldksd\n"
+ "asd sjdjska 10-11-1989 ksjdkds 1-11-1456\n"
+ "skdasdsa\n"
+ "dasdlkj kajsd kjaksdj ksadjk jsadkdj a 1/1 - 1899";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}