const regex = /\d{1,2}[-\/]\d{1,2}\s?[\-\/]\s?\d{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{1,2}[-\\\/]\\d{1,2}\\s?[\\-\\\/]\\s?\\d{4}', 'gm')
const str = `tetsts kmasjdkjsad kajsdkjasdkj kjadjaksd 45-12-2020 lkdlksldksd
asd sjdjska 10-11-1989 ksjdkds 1-11-1456
skdasdsa
dasdlkj kajsd kjaksdj ksadjk jsadkdj a 1/1 - 1899`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);