$re = '/^\[\[\%([A-z0-9\-]+)\?\s+\&namespace\=\`(.*)\`\s+\&topic\=\`(.*)\`\]\]/Uis';
$str = '[[%mt4se-amuk-tradeterminal-4-p-59? &namespace=`main_uk` &topic=`TradeTerminal`]]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);