$re = '/(?<=[a-zA-Z])\d+|\d+(?=[a-zA-Z])/m';
$str = 'I need this number inside my wor5d, but also this word3 and this 4word, but not this 1 and not this 555.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);