$re = '/^(?:\{[^{}:]*:[^:{}]*}|[^{:}])+$/m';
$str = 'Valid case:
{test:test1} {test2:test3} test4 test5
Invalid case:
{test:}, {test1: test2, test1: test3}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);