#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![ -]|\d+$)(?:(?![ -]$)[\pL\pN -])+$"
Local $sString = "Street" & @CRLF & _
"Some-Street" & @CRLF & _
"Street" & @CRLF & _
"1 st street" & @CRLF & _
"street 5" & @CRLF & _
"" & @CRLF & _
"Street " & @CRLF & _
" Street" & @CRLF & _
"Street-" & @CRLF & _
"-Street" & @CRLF & _
"111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")