re = /token=(.*?)&filter=\s*(.+?)\s+(.+)/m
str = 'api/evenSession/123123123/eventSession?token=1234656&filter= chris moreno'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end