$re = '/(\[\[File:[^|]*).*?(\]\])/';
$str = '[[File:My Image.png|400px|thumb|center|My Image]]
[[File:My Image.png|400px|thumb|center]] [[File:My Image.png|400px|thumb|center]]
[[File:My Image.png|400px|thumb]]
[[File:My Image.png|400px]]
[[File:My Image.png]]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);