// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(5$|5.0$|5.00$|^(?:4(?:\.[0-9]{0,2})?|[1-4](?:\.[0-9]{0,2})?|1?\.[0-9]{0,2})$)").unwrap();
let string = "1.0
0.0
0.1
0.2
0.9
0.19
1.1
3.0
4.0
5.0
5.00
5.1
4.11
5.22
0
4.99
5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}