$re = '/.*(-(W|R)( |")(([0-9a-fA-F]{2}) ){2,20}).*/m';
$str = 'pnscan -W"05 5A 37" -R"FF 00 FF" 192.168.0.32 145
/usr/local/bin/pnscan -t512 -R 6f 73 3a 4c 69 6e 75 78 -W 2a 31 0d 0a 24 34 0d 0a 69 6e 66 6f 0d 0a 221.0.0.0/16 6379
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);