import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\{,]\\s*\"([^\"]*)\"\\s*\\:\\s*\"([^\"]*)\"";
final String string = "{\"d\":{\"results\":[{\"service manager\":\"Noelle April\",\"turnover\":\"156\"}\n"
+ "{\"commission agent\":\"Elon Julius\",\"turnover\":\"665\"}\n"
+ "{\"sales assistant\":\"Landen Boden\",\"turnover\":\"585\"}\n"
+ "{\"sales manager\":\"Yisroel Armando\",\"turnover\":\"826\"}\n"
+ "{\"service manager\":\"Hanna Lillie\",\"turnover\":\"355\"}\n"
+ "{\"commission agent\":\"Memphis Malachi\",\"turnover\":\"669\"}\n"
+ "{\"sales manager\":\"Araceli Nellie\",\"turnover\":\"496\"}\n"
+ "{\"sales manager\":\"Cristian Sawyer\",\"turnover\":\"819\"}]}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}