// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)nothing( *)(?:^|)(new|to|at|another|really|about|perfect|great)").unwrap();
let string = "I would put this on \"nothing\" since I can think of a things at that area forever";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}