package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{[^{}]*\}[^{}]+p\. [0-9]+`)
var str = `{Hello}, [1234] (Test). This is sample data used to answer a question {Hello2} [Ch.8 p. 87 gives more information about...
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}