// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+H?\d*M?\d*S?$").unwrap();
let string = "1M3W4D22H6M3S
10D12H
10M
1Y8W3D
2M12H";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}