# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"parent\s*\{\s*type\s*\{[^{}]*subtype\s+TestSubType\s*\{[^{}]*element\s+TestElement\s*\{[^{}]*attributes\s*\{[^{}]*value\s+testvalue[^{}]*\}[^{}]*owner\s+person1"
test_str = ("parent {\n"
" type {\n"
" subtype TestSubType {\n"
" element TestElement {\n"
" attributes {\n"
" name testname;\n"
" description testdescription;\n"
" count 1234;\n"
" value testvalue;\n"
" }\n"
" owner person1;\n"
" }\n"
" }\n"
" subtype TestSubType1 {\n"
" element TestElement1 {\n"
" attributes {\n"
" name testname1;\n"
" description testdescription1;\n"
" count 1;\n"
" value 1\n"
" }\n"
" owner person2;\n"
" }\n"
" }\n"
" subtype TestSubType2 {\n"
" element TestElement2 {\n"
" attributes {\n"
" name testname2;\n"
" description testdescription2;\n"
" count 2;\n"
" value 2\n"
" }\n"
" owner unknown;\n"
" }\n"
" }\n"
" subtype TestSubType3 {\n"
" element TestElement3 {\n"
" attributes {\n"
" name testname3;\n"
" description testdescription3;\n"
" count 3;\n"
" value 3\n"
" }\n"
" owner unknown;\n"
" }\n"
" }\n"
" subtype TestSubType3 {\n"
" element TestElement4 {\n"
" attributes {\n"
" name testname4;\n"
" description testdescription4;\n"
" count 4;\n"
" value 4\n"
" }\n"
" owner unknown;\n"
" }\n"
" }\n"
" subtype TestSubType4 {\n"
" element TestElement5 {\n"
" attributes {\n"
" name testname5;\n"
" description testdescription5;\n"
" count 5;\n"
" value 5\n"
" }\n"
" owner unknown;\n"
" }\n"
" }\n"
" subtype TestSubType5 {\n"
" element TestElement6 {\n"
" attributes {\n"
" name testname6;\n"
" description testdescription6;\n"
" count 6;\n"
" value 6\n"
" }\n"
" owner unknown;\n"
" }\n"
" }\n"
" subtype TestSubType6 {\n"
" element TestElement7 {\n"
" attributes {\n"
" name testname7;\n"
" description testdescription7;\n"
" count 7;\n"
" value 7\n"
" }\n"
" owner unknown;\n"
" }\n"
" }\n"
" subtype TestSubType7 {\n"
" element TestElement8 {\n"
" attributes {\n"
" name testname8;\n"
" description testdescription8;\n"
" count 8;\n"
" value 8\n"
" }\n"
" owner unknown;\n"
" }\n"
" }\n"
" subtype TestSubType8 {\n"
" element TestElement9 {\n"
" attributes {\n"
" name testname9;\n"
" description testdescription9;\n"
" count 9;\n"
" value 9\n"
" }\n"
" owner unknown;\n"
" }\n"
" }\n"
" subtype TestSubType9 {\n"
" element TestElement10 {\n"
" attributes {\n"
" name testname10;\n"
" description testdescription10;\n"
" count 10;\n"
" value 10\n"
" }\n"
" owner unknown;\n"
" }\n"
" }\n"
" subtype TestSubType10 {\n"
" element TestElement11 {\n"
" attributes {\n"
" name testname11;\n"
" description testdescription11;\n"
" count 11;\n"
" value 11\n"
" }\n"
" owner unknown;\n"
" }\n"
" }\n"
" }\n"
"}\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.