using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(www\.|https?:\/\/)?[a-z0-9]+\.[a-z0-9]{2,4}\S*\b";
string input = @"example.co.uk (main site: example.com)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}