package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(www\.|https?:\/\/)?[a-z0-9]+\.[a-z0-9]{2,4}\S*\b`)
var str = `example.co.uk (main site: example.com)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}