import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((https?:(?:\\/\\/)?)(?!(www\\.)*youtube\\.com|youtu\\.be|(www\\.|rover\\.)*ebay\\.com|(www\\.)*amazon\\.)[A-Za-z0-9.\\-]+[A-Za-z0-9.\\-]+)((?:\\/[\\+~%\\/.\\w\\-_]*)?\\??(?:[\\-\\+=&;%@.\\w_]*)#?(?:[\\w]*))?)";
final String string = "https://youtube.com\n\n"
+ "https://www.amazon.com\n\n"
+ "https://www.notamazon.com\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}