using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<name>.{39})(?<port>.{15})(?<info>.{26})(?<protocol>.+)";
string input = @"Windows remote mgmt RPC 135 @FirewallAPI TCP
Corenet-12345 421 TCP
Port 75 and 443 UDP";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}