const regex = /(?<name>.{39})(?<port>.{15})(?<info>.{26})(?<protocol>.+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<name>.{39})(?<port>.{15})(?<info>.{26})(?<protocol>.+)', 'g')
const str = `Windows remote mgmt RPC 135 @FirewallAPI TCP
Corenet-12345 421 TCP
Port 75 and 443 UDP`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}