re = /^[^:\n]*:.*(*SKIP)(*FAIL)|\)/m
str = 'Hello1 (
First : (),
Second )
Hello2 (
First
)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end