package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)href="(http(s)?:\/\/[\w-_.\/]+|#\w+)"`)
var str = `<a href="http://github.com/den2736">
<a href="https://github.com/den2736">
<a href="#ancor">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}