package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]{3}( to |-)[A-Z]{3}`)
var str = `I recently traveled YWG-LHR and returned home from EDI to YWG with AC Rouge. I must say I was pleasantly surprised with how well the trip went in both directions, but I'm glad I didn't have to transit in ORD.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}