package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((?:https?:)?\/\/)?((?:www|m)\.)?((?:youtube\.com|youtu.be))(\/(?:[\w\-]+\?v=|embed\/|v\/)?)([\w\-]+)(\S+)?$`)
var str = `https://www.youtube.com/watch?v=
https://www.youtube.com/watch?v=`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}