#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\bhackerrank\b"
Local $sString = "I love #hackerrank" & @CRLF & _
"I just scored 27 points in the Picking Cards challenge on #HackerRank" & @CRLF & _
"I just signed up for summer cup @hackerrank" & @CRLF & _
"interesting talk by hari, co-founder of hackerrank"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")