#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=\d{1,2}\s*(?:h|m))(?:(\d{1,2})\s*h)?\s*(?:\s?(\d{1,2})\s*m)?"
Local $sString = "8h20m 10m 8h left " & @CRLF & _
" 8 h 30 m left" & @CRLF & _
"8h left" & @CRLF & _
"8h 20m left" & @CRLF & _
"57m left" & @CRLF & _
"1m left"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")