use strict;
my $str = '8h20m 10m 8h left
8 h 30 m left
8h left
8h 20m left
57m left
1m left';
my $regex = qr/(?=\d{1,2}\s*(?:h|m))(?:(\d{1,2})\s*h)?\s*(?:\s?(\d{1,2})\s*m)?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}