using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*?0.*0)[02aQ][a-zA-Z0-9$]+[Sd]$";
string input = @"(1). Starting with 0/2/a/Q.
(2). Must end with S/d.
(3). Must contain at least two 0.
(5). Only contain Alphanumeric character and the only special character '$' (Dollar sign).
0abcde0fS
200abcd
x00s
0abcdefS";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}