import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[(([^ \\[\\]\\t\\r\\n]+)( *([^ \\[\\]\\t\\r\\n]+))*)\\]$";
final String string = "[bracketed text]\n"
+ "[more_bracketed_text]\n\n"
+ "not fully [bracketed]\n"
+ "[has a ] close bracket in middle]\n"
+ "[space after] \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}