const regex = /^\[(([^ \[\]\t\r\n]+)( *([^ \[\]\t\r\n]+))*)\]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[(([^ \\[\\]\\t\\r\\n]+)( *([^ \\[\\]\\t\\r\\n]+))*)\\]$', 'gm')
const str = `[bracketed text]
[more_bracketed_text]
not fully [bracketed]
[has a ] close bracket in middle]
[space after]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}