#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(tags:)"
Local $sString = "---" & @CRLF & _
"anykey: somevalue" & @CRLF & _
"tags:" & @CRLF & _
" - sometag" & @CRLF & _
" - sometag2" & @CRLF & _
"anyotheryamlkey: somevalue" & @CRLF & _
"anyotheryamlkey2: " & @CRLF & _
" - somevalue1" & @CRLF & _
"---" & @CRLF & _
"" & @CRLF & _
"Main body text." & @CRLF & _
"More text."
Local $sSubst = "$1\n - m/diary"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)